Financial Services

PeopleSoft supported platforms

Further information

  • Applications supported
  • Applications supported Frequently Asked Questions

PeopleSoft 9 is web based, and is certified with the platforms listed on this page.

 

Firefox 7

  • Apple Mac OS X (Intel) (32-bit) 10.5
  • Apple Mac OS X (Intel) (64-bit) 10.7
  • Apple Mac OS X (Intel) (64-bit) 10.6
  • Linux x86-64 Red Hat Enterprise Linux 5
  • Linux x86-64 Oracle Linux 5
  • Microsoft Windows (32-bit) XP
  • Microsoft Windows (32-bit) Vista
  • Microsoft Windows (32-bit) 7
  • Microsoft Windows x64 (64-bit) 7
  • Microsoft Windows x64 (64-bit) Vista

Back to top

Firefox 3.6

  • Microsoft Windows (32-bit) XP
  • Microsoft Windows (32-bit) Vista
  • Linux x86 Oracle Linux 5
  • Microsoft Windows (32-bit) 2003
  • Apple Mac OS X (Intel) 10.6
  • Apple Mac OS X (Intel) 10.5
  • Apple Mac OS X (PowerPC) 10.4
  • Microsoft Windows (32-bit) 7
  • Microsoft Windows x64 (64-bit) 7
  • Microsoft Windows x64 (64-bit) 2008 R2

Back to top

Internet Explorer 9

  • Microsoft Windows (32-bit) Vista
  • Microsoft Windows (32-bit) 7
  • Microsoft Windows x64 (64-bit) 7
  • Microsoft Windows x64 (64-bit) 2008 R2
  • Microsoft Windows x64 (64-bit) Vista

Back to top

Internet Explorer 8

  • Microsoft Windows (32-bit) XP
  • Microsoft Windows (32-bit) Vista
  • Microsoft Windows x64 (64-bit) Vista
  • Microsoft Windows x64 (64-bit) 2008 R2
  • Microsoft Windows x64 (64-bit) 2008
  • Microsoft Windows (32-bit) 2003
  • Microsoft Windows (32-bit) 7
  • Microsoft Windows x64 (64-bit) 7

Back to top

Internet Explorer 7

  • Microsoft Windows (32-bit) XP
  • Microsoft Windows (32-bit) Vista
  • Microsoft Windows (32-bit) 2003

Back to top

Safari 5

  • Apple Mac OS X (Intel) 10.6
  • Apple Mac OS X (Intel) 10.5

Back to top

Safari 4

  • Apple Mac OS X (Intel) 10.6
  • Apple Mac OS X (Intel) 10.5
  • Apple Mac OS X (PowerPC) 10.4

Back to top

Safari 3

  • Apple Mac OS X (Intel) 10.5
  • Apple Mac OS X (PowerPC) 10.4

Note: For UPK (PeopleSoft Online Training) Internet Explorer 8 or 9, or Firefox 10, is required.

Also, please ensure any popup-blocking software is either turned off or allows Financial Sevices websites, and that JavaScript / Active Scripting is enabled. This includes the Windows XP Service Pack 2 popup-blocking feature.

If for some reason you are unable to use a supported browser, you may be eligible to use the PeopleSoft published application on the IS Citrix farm.

Financial Services can only provide support for PeopleSoft 9.1 if you are using one of the supported browsers listed above.